您的位置:首页 > 其它

杭电1004(map的应用)之Let the Balloon Rise

2016-11-06 15:13 459 查看
[align=left]Problem Description[/align]
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

[align=left]Sample Input[/align]

5
green
red
blue
red
red
3
pink
orange
pink
0

 

[align=left]Sample Output[/align]

red
pink

AC代码如下:
#include <iostream>
#include <map>
#include <string>
#include <cstring>
using namespace std;

map <string,int> s;

int main()
{
int n;
string str;
char a[1010][20];
while(cin>>n , n)
{
for(int i=0;i<n;i++)
{
cin>>a[i];
s[a[i]]++;
}
int maxi=0;
for(int i=0;i<n;i++)
{
if(s[a[i]]>maxi)
{
maxi=s[a[i]];
}
}
for(int i=0;i<n;i++)
{
if(s[a[i]]==maxi)
{
cout<<a[i]<<endl;
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: