您的位置:首页 > 其它

HDU5122 K.Bro Sorting 树状数组

2016-11-06 00:55 211 查看
题目链接:HDU5122


K.Bro Sorting

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 2636    Accepted Submission(s): 1226


Problem Description

Matt’s friend K.Bro is an ACMer.

Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after
this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence
in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .

 

Input

The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).

The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.

The sum of N in all test cases would not exceed 3 × 106.

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.

 

Sample Input

2
5
5 4 3 2 1
5
5 1 2 3 4

 

Sample Output

Case #1: 4
Case #2: 1

HintIn the second sample, we choose “5” so that after the first round, sequence becomes “1 2 3 4 5”, and the algorithm completes.

 
题意:规定一种排序方法,随机的选一个数,如果右边的数比它小,就交换位置,一直到右边的数比它大为止。算法一直持续到排序完成为止。问最少需要选几个数进行操作才能排序完成。
题目分析:对于每个数,如果其右边的所有数有比它小的,就需要对这个数操作,同时最优的取法为从最大的数开始移动,因此不需要重复选一个数,只需统计需要操作的数个数即可。可以用求逆序数的方式用树状数组统计。

//
//  main.cpp
//  K.Bro Sorting
//
//  Created by teddywang on 2016/11/5.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e6+10;
int r[maxn],c[maxn],p[maxn],s[maxn];
int n,t;

int lowbit(int x)
{
return x&(-x);
}

void update(int x,int num)
{
while(x<=n)
{
c[x]+=num;
x+=lowbit(x);
}
}

int getsum(int x)
{
int s=0;
while(x>0)
{
s+=c[x];
x-=lowbit(x);
}
return s;
}

int main()
{
cin>>t;
int k=1;
while(t--)
{
cin>>n;
memset(r,0,sizeof(r));
memset(c,0,sizeof(c));
for(int i=1;i<=n;i++)
{
scanf("%d",&s[i]);
p[s[i]]=i;
}
int ans=0;
for(int i=n;i>=1;i--)
{
r[s[i]]=getsum(s[i]);
if(r[s[i]]) ans++;
//printf("%d %d\n",s[i],r[s[i]]);
update(s[i],1);
}
printf("Case #%d: %d\n",k++,ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: