您的位置:首页 > 其它

HDU 2680 Choose the best route

2016-11-05 16:38 357 查看
Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13397 Accepted Submission(s): 4338

Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1<=s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5

1 2 2

1 5 3

1 3 4

2 4 7

2 5 6

2 3 5

3 5 1

4 5 1

2

2 3

4 3 4

1 2 3

1 3 4

2 3 2

1

1

Sample Output

1

-1

Author

dandelion

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟

解析:多源最短路,不过本题可以转化为单源最短路,因为终点是相同的。反向建图后,终点到各点的距离等于原图各点到终点的距离。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int INF = 0x3f3f3f3f;
const int MAXN = 1000+5;
int e[MAXN][MAXN];
int dis[MAXN];
bool vis[MAXN];
int n, m, s;

void dijkstra()
{
memset(vis, 0, sizeof vis);
vis[s] = true;
for(int i = 1; i <= n; ++i)
dis[i] = e[s][i];
for(int i = 1; i < n; ++i){
int min_dis = INF, u;
for(int j = 1; j <= n; ++j){
if(!vis[j] && dis[j] < min_dis)
min_dis = dis[u = j];
}
if(min_dis == INF)
return;
vis[u] = true;
for(int v = 1; v <= n; ++v)
dis[v] = min(dis[v], dis[u]+e[u][v]);
}
}

void solve()
{
dijkstra();
int res = INF;
int w, b;
scanf("%d", &w);
while(w--){
scanf("%d", &b);
res = min(res, dis[b]);
}
printf("%d\n", res == INF ? -1 : res);
}

int main()
{
while(~scanf("%d%d%d", &n, &m, &s)){
for(int i = 1; i <= n; ++i)
for(int j = 1; j <= n; ++j)
e[i][j] = (i == j ? 0 : INF);
int p, q, t;
while(m--){
scanf("%d%d%d", &p, &q, &t);
e[q][p] = min(e[q][p], t);  //反向建图,p->q变为q->p
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: