您的位置:首页 > 其它

HDU - 1222 Wolf and Rabbit(加法生成元)

2016-11-05 13:21 507 查看
题目:

Description

There is a hill with n holes around. The holes are signed from 0 to n-1. 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 

Sample Input

2
1 2
2 2


Sample Output

NO
YES


一个非常简单的数论问题,判断m是否是mod n的加法生成元。

只要看m和n是否互质即可。

代码:

#include<iostream>
using namespace std;

int gcd(int a, int b)
{
if (b)return gcd(b, a%b);
return a;
}

int main()
{
int n, a, b;
cin >> n;
while (n--)
{
cin >> a >> b;
if (gcd(a, b) == 1)cout << "NO\n";
else cout << "YES\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: