您的位置:首页 > 其它

HDU - 1220 Cube

2016-11-05 13:13 363 查看
题目:

Description

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes
may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points. 

Process to the end of file. 

Input

There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30). 

Output

For each test case, you should output the number of pairs that was described above in one line. 

Sample Input

1
2
3


Sample Output

0
16
297


这个很容易推导,只要用所有的二元组C(n^3,3),去掉不满足条件的3*n*n*(n-1)即可得到答案

代码:

#include<iostream>
using namespace std;

int main()
{
int n, a;
while (cin >> n)
{
a = n*n*(n + 1) + n - 6;
cout << n*n*(n - 1)*a / 2 << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: