您的位置:首页 > 编程语言 > C语言/C++

POJ 2282 The Counting Problem

2016-11-02 18:43 447 查看
Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.
Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.
Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.
Sample Input
1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output
1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

Source
Shanghai 2004
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

(很容易错的)数论(模拟)~

对于每一个数字,枚举它在每一个位置上的次数,然后再加起来。

求区间[m,n]上的结果,就相当于是求m上的结果-(n-1)上的结果。

因为0左面要保证是不为0的,所以0要与其它数分开计算。

对于一个数n>0 && n<=9且位于j位,分n>num[j],n==num[j]和n<num[j]计算,均为左面的种类数乘右面的种类数~

(很麻烦的,最好打好草稿后再写代码~)

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

int n,m,num[12],a[10],tot;

int mi(int u)
{
int kkz=1;
for(int i=1;i<=u;i++) kkz*=10;
return kkz;
}

void cal(int u,int v)
{
tot=0;
while(u) num[++tot]=u%10,u/=10;
for(int i=1;i<=9;i++)
for(int j=1;j<=tot;j++)
{
if(i>num[j])
{
int now=0;
for(int k=tot;k>j;k--) now=now*10+num[k];
a[i]+=v*(now)*mi(j-1);
}
else if(i==num[j])
{
int now=0;
for(int k=tot;k>j;k--) now=now*10+num[k];
a[i]+=v*now*mi(j-1);now=0;
for(int k=j-1;k;k--) now=now*10+num[k];
a[i]+=v*(now+1);
}
else
{
int now=0;
for(int k=tot;k>j;k--) now=(now*10+num[k]);now++;
a[i]+=v*now*mi(j-1);
}
}
for(int j=1;j<tot;j++)
{
if(!num[j])
{
int now=0;
for(int k=tot;k>j;k--) now=now*10+num[k];
a[0]+=v*(now-1)*mi(j-1);now=0;
for(int k=j-1;k;k--) now=now*10+num[k];
a[0]+=v*(now+1);
}
else
{
int now=0;
for(int k=tot;k>j;k--) now=now*10+num[k];
a[0]+=v*now*mi(j-1);
}
}
}

int main()
{
while(scanf("%d%d",&n,&m)==2 && n)
{
memset(a,0,sizeof(a));
if(m<n) swap(n,m);cal(m,1);cal(n-1,-1);
for(int i=0;i<=9;i++) printf("%d ",a[i]);printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 数论 模拟