您的位置:首页 > 其它

poj 2240 Arbitrage ([kuangbin带你飞]专题四 最短路练习)

2016-11-02 18:33 405 查看
Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound,
1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name
of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate
from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0


Sample Output

Case 1: Yes
Case 2: No


題意:金币之间可以转换,问转换到最后能不能盈利

题解:flod求环,看自己到自己的值能不能大于1

#include <iostream>
#include <string.h>
#include<cstdio>
using namespace std;
#define MAXC 100
#define MAXV 50

double map[MAXV][MAXV];
int n,m;

void Input(){
char s[MAXV][MAXC],a[MAXC],b[MAXC];
int i,k,j;
double c;
for(i=0;i<=n;i++)
for(j=0;j<=n;j++)
if(i==j)
map[i][j]=1;
else
map[i][j]=0;
for(i=1;i<=n;i++) scanf("%s",s[i]);
scanf("%d\n",&m);
for(i=1;i<=m;i++){
scanf("%s %lf %s",a,&c,b);
for(j=1;j<=n;j++)
if(!strcmp(s[j],a)) break;
for(k=1;k<=n;k++)
if(!strcmp(s[k],b)) break;
map[j][k]=c;
}
}

void floyd(){
int i,j,k;
for(k=1;k<=n;k++)
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
if(map[i][k]*map[k][j]>map[i][j])
map[i][j]=map[i][k]*map[k][j];
}

int main(){
int cas=1,i;
while(scanf("%d",&n) && n){
Input();
floyd();
printf("Case %d: ",cas++);
for(i=1;i<=n;i++)
if(map[i][i]>1) break;
if(i>n) printf("No\n");
else printf("Yes\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息