您的位置:首页 > 大数据 > 人工智能

HDU 2476 String painter(区间DP)

2016-11-02 16:38 471 查看

原题地址

String painter

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3726 Accepted Submission(s): 1740

[align=left]Problem Description[/align]
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other
character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

[align=left]Input[/align]
Input contains multiple cases. Each case consists of two lines:

The first line contains string A.

The second line contains string B.

The length of both strings will not be greater than 100.

[align=left]Output[/align]
A single line contains one integer representing the answer.

[align=left]Sample Input[/align]

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

[align=left]Sample Output[/align]

6
7

题意:
给你两个字符串,让你从字符串1刷成字符串2的样子,每次你只能将一个区间内的字符刷成同一个字符。

思路:
区间DP。一开始将字符串初始为空串,记dp[ i ][ j ]为,将从 i ~ j 的字符串刷成目标串所用的最少步数。可以将dp[ i ][ j ]初始化为dp[ i-1 ][ j ],然后比较新添加的一位如果和区间内的p位相同,则dp[i][j] = min(dp[i][j],(dp[i+1][p]+dp[p+1][j]))

[align=left]AC代码:[/align]

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>

using namespace std;

char str1[111],str2[111];
int dp[111][111];
int ans[111];
int main()
{
while(~scanf("%s",&str1))
{
scanf("%s",&str2);
int i,j,l;
l=strlen(str1);
memset(dp,0,sizeof(dp));
for(j=0;j<l;j++)
{
for(i=j;i>=0;i--)
{
dp[i][j]=dp[i+1][j]+1;
for(int p=i+1;p<=j;p++)
{
if(str2[i]==str2[p])
dp[i][j] = min(dp[i][j],(dp[i+1][p]+dp[p+1][j]));
}
}
}
for(int i=0;i<l;i++)
{
ans[i]=dp[0][i];
}
for(int i=0;i<l;i++)
{
if(str1[i]==str2[i])
{
ans[i]=ans[i-1];
}
else
{
for(int j=0;j<i;j++)
{
ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
}
}
}
printf("%d\n",ans[l-1]);
}
return 0;
}




[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  区间DP