您的位置:首页 > 其它

poj 3660 Cow Contest ([kuangbin带你飞]专题四 最短路练习)

2016-11-02 15:45 477 查看
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B≤ N; A ≠ B), then cow A will always
beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results
of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5


Sample Output

2


题目大意:给出牛之间的强弱关系,让你确定有多少头牛能够确定其排名.

解题思路:只要知道眉头牛和其他牛的强弱关系就可以知道这个牛的强弱,,

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m;
const int maxn = 100+10;
int mp[maxn][maxn];

int main(){
while(scanf("%d%d",&n,&m)!=EOF){
memset(mp,0,sizeof(mp));
for(int i=1;i<=m;i++){
int a,b;
scanf("%d%d",&a,&b);
mp[a][b]=1;
}
for(int k=1;k<=n;k++){
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(mp[i][k] && mp[k][j]) mp[i][j]=1;
}
}
}
int ans=0;
for(int i=1;i<=n;i++){
int res= n-1;
for(int j=1;j<=n;j++){
if(mp[i][j] || mp[j][i]) res--;
}
if(!res) ans++;
}
printf("%d\n",ans);
}

return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息