您的位置:首页 > 其它

简单枚举类型——植物与颜色

2016-11-01 22:39 489 查看


简单枚举类型——植物与颜色

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 


Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。


Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 


Example Input

blue
yellow
purple



Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.



Hint

 请用枚举类型实现。

#include<stdio.h>

#include<string.h>

enum color { Rose,Poppies,Sunflower,Grass,Bluebells,Violets,

};

int main()

{
char c[31];
int temp;
while(scanf("%s",c)!=EOF)
{
if(strcmp(c,"red")==0)
temp=0;
else if(strcmp(c,"orange")==0)
temp=1;
else if(strcmp(c,"yellow")==0)
temp=2;
else if(strcmp(c,"green")==0)
temp=3;
else if(strcmp(c,"blue")==0)
temp=4;
else if(strcmp(c,"violet")==0)
temp=5;
else temp=6;
if(temp>=0&&temp<=5)
{
switch((enum color)temp)
{
case 0:printf("Rose are red.\n");break;
case 1:printf("Poppies are orange.\n");break;
case 2:printf("Sunflower are yellow.\n");break;
case 3:printf("Grass are green.\n");break;
case 4:printf("Bluebells are blue.\n");break;
case 5:printf("Violets are violet.\n");break;
}
}
else printf("I don't know about the color %s.\n",c);
}
return 0;

 }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: