您的位置:首页 > 其它

POJ 3164 Command Network 最小树形图 模板题

2016-11-01 13:41 447 查看
Command Network
Time Limit: 1000MS      Memory Limit: 131072K
Total Submissions: 17036        Accepted: 4892

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

Source
POJ Monthly--2006.12.31, galaxy


G++ %.2lf输出无限wa 换%.2f就好了

//O(VE)方法
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
//#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

const int MAXN = 1010;
const int MAXM = 10010+MAXN;
const ll INF=1e18+1;
const double EPS=1e-5;
struct Edge
{
int u,v;
double cost;
};
pii coord[MAXN];
Edge edge[MAXM];
int pre[MAXN],id[MAXN],visit[MAXN];
double in[MAXN];
inline double dis(pii&a,pii&b){
return sqrt((a.first-b.first)*(a.first-b.first)+(a.second-b.second)*(a.second-b.second));
}
double zhuliu(int root,int n,int m,Edge edge[])//PS:会改变edge[]
{
double res = 0;
int u,v;
while(1)
{
for(int i = 0;i < n;i++)
in[i] = INF;//入边边权为inf
for(int i = 0;i < m;i++)
if(edge[i].u != edge[i].v && edge[i].cost < in[edge[i].v])
{//找出所有点的最小入边集E0
pre[edge[i].v] = edge[i].u;
in[edge[i].v] = edge[i].cost;
}
for(int i = 0;i < n;i++)
if(i != root && in[i] == INF)
return -1;//有除根节点外的点 无入边 不存在最小树形图
int tn = 0;
memset(id,-1,sizeof(id));
memset(visit,-1,sizeof(visit));
in[root] = 0;
for(int i = 0;i < n;i++)//找环
{
res += in[i];
v = i;
while( visit[v] != i && id[v] == -1 && v != root)
{
visit[v] = i;
v = pre[v];
}
if( v != root && id[v] == -1 )//存在环
{
for(int u = pre[v]; u != v ;u = pre[u])//将环中的点全部标为tn号点
id[u] = tn;
id[v] = tn++;
}
}
if(tn == 0)break;//没有有向环
for(int i = 0;i < n;i++)//为未被标号的点标号
if(id[i] == -1)
id[i] = tn++;

for(int i = 0;i < m;)
{
v = edge[i].v;
edge[i].u = id[edge[i].u];
edge[i].v = id[edge[i].v];
if(edge[i].u != edge[i].v)
edge[i++].cost -= in[v];//E0已经被添加进res了 减去入边权
else
swap(edge[i],edge[--m]);
}
n = tn;
root = id[root];
}
return res;
}
int main()
{
//freopen("/home/lu/文档/r.txt","r",stdin);
//freopen("/home/lu/文档/w.txt","w",stdout);
int n,m;
while(~scanf("%d%d",&n,&m)){
for(int i=0;i<n;++i){
scanf("%d%d",&coord[i].first,&coord[i].second);
}
int a,b;
for(int i=0;i<m;++i){
scanf("%d%d",&a,&b);
--a,--b;
double w=dis(coord[a],coord[b]);
edge[i]={a,b,w};
}
double ans=zhuliu(0,n,m,edge);
if(ans+EPS<0)
puts("poor snoopy");
else
printf("%.2f\n",ans);
}
return 0;
}


//邻接矩阵实现 O(V^3)
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

const int N=100+5;
const int M=1e4+5;
double mp

;//邻接矩阵 只用1-n 舍弃0
bool visited
;
bool flag
;//标记是否是缩点
int pre
;//pre[i]连接到i点
pii coord
;
const double EPS=1e-5;

inline double dis(pii&a,pii&b){
return sqrt((a.first-b.first)*(a.first-b.first)+(a.second-b.second)*(a.second-b.second));
}

double zhuliu(int n){
double sum=0;
for(int i=1;i<=n;++i){
mp[i][i]=INF;
visited[i]=flag[i]=false;
}
pre[1]=1;//根节点为1
int i,j;
while(true){
//计算最短弧集合E0
for(i=2;i<=n;++i){
if(flag[i])
continue;
pre[i]=i;
for(j=1;j<=n;++j){
if(!flag[j]&&mp[j][i]<mp[pre[i]][i])
pre[i]=j;
}
if(pre[i]==i)//点i没有入边 不存在最小树形图
return -1;
}
//检查E0是否存在环
for(i=2;i<=n;++i){
if(flag[i])
continue;
//从i点开始找环
for(j=1;j<=n;++j)
visited[j]=false;
visited[1]=true;
j=i;
do{
visited[j]=true;
j=pre[j];
}while(!visited[j]);

if(j==1)//回到了起点 不存在环
continue;
//收缩这个环
i=j;
//保存整个环权值 累加进原图最小树形图中
do{
sum+=mp[pre[j]][j];
j=pre[j];
}while(j!=i);
j=i;
//对环上的点连接的边进行处理
do{
for(int k=1;k<=n;++k)
if(!flag[k]&&mp[k][j]<INF-EPS&&k!=pre[j])
mp[k][j]-=mp[pre[j]][j];
j=pre[j];
}while(j!=i);
//缩点 环缩成i号点 环上所有边转移到i上
for(j=1;j<=n;++j){
if(j==i)
continue;
for(int k=pre[i];k!=i;k=pre[k]){
mp[i][j]=min(mp[i][j],mp[k][j]);
mp[j][i]=min(mp[j][i],mp[j][k]);
}
}
//标记环上这些点被缩掉了
for(j=pre[i];j!=i;j=pre[j])
flag[j]=true;
//跳出 求新图的最小树形图
break;
}
if(i==n+1){//找到最小树形图了
for(i=2;i<=n;++i)
if(!flag[i])
sum+=mp[pre[i]][i];
break;
}
}
return sum;
}

int main()
{
//freopen("/home/lu/文档/r.txt","r",stdin);
//freopen("/home/lu/文档/w.txt","w",stdout);
int n,m;
while(~scanf("%d%d",&n,&m)){
for(int i=1;i<=n;++i){
scanf("%d%d",&coord[i].first,&coord[i].second);
fill(mp[i],mp[i]+n+1,INF);
}
int a,b;
for(int i=1;i<=m;++i){
scanf("%d%d",&a,&b);
double w=dis(coord[a],coord[b]);
mp[a][b]=w;//=mp[b][a]=w;
}
double ans=zhuliu(n);
if(ans+EPS<0)
puts("poor snoopy");
else
printf("%.2f\n",ans);
}
return 0;
}


130d2
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 图论 最小树形图