您的位置:首页 > 其它

hdu 5949 Relative atomic mass 2016ACM/ICPC沈阳赛区现场赛B

2016-10-31 20:30 483 查看
Problem Description

Relative atomic mass is a dimensionless physical quantity, the ratio of the average mass of atoms of an element (from a single given sample or source) to 12of
the mass of an atom of carbon-12 (known as the unified atomic mass unit).

You need to calculate the relative atomic mass of a molecule, which consists of one or several atoms. In this problem, you only need to process molecules which contain hydrogen atoms, oxygen atoms, and carbon atoms. These three types of atom are written as
’H’,’O’ and ’C’ repectively. For your information, the relative atomic mass of one hydrogen atom is 1, and the relative atomic mass of one oxygen atom is 16 and the relative atomic mass of one carbon atom is 12. A molecule is demonstrated as a string, of which
each letter is for an atom. For example, a molecule ’HOH’ contains two hydrogen atoms and one oxygen atom, therefore its relative atomic mass is 18 = 2 * 1 + 16.

Input

The first line of input contains one integer N(N ≤ 10), the number of molecules. In the next N lines, the i-th line contains a string, describing the i-th molecule. The length of each string would not exceed 10.

Output

For each molecule, output its relative atomic mass.

Sample Input

5
H
C
O
HOH
CHHHCHHOH


Sample Output

1
12
16
18
46


求只有C、H、O元素的相对分子质量

直接做即可

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
int T;
scanf("%d",&T);
while(T>0)
{
T--;
string x;
cin>>x;
int sum=0;
int lx=x.size();
int i;
for(i=0;i<=lx-1;i++)
{
if(x[i]=='C')
sum+=12;
else if(x[i]=='O')
sum+=16;
else
sum+=1;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: