您的位置:首页 > 其它

POJ 1840Eqs(hash)

2016-10-31 20:12 405 查看

Eqs

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15934 Accepted: 7813
Description
Consider equations having the following form:

a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0

The coefficients are given integers from the interval [-50,50].

It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input
The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output
The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47

Sample Output
654


题意:给定a1, a2, a3, a4, a5,求a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0的解,x1-x5的范围为[50)U(50];
题解:用哈兮做,将其分解为a1x13+ a2x23= -(a3x33+ a4x43+ a5x53),定义hash有short;

#include <stdio.h>
#include <string.h>

short hash[25000001];

int main()
{
int a, b, c, d, e, i, j, sum, k, S;
while(~scanf("%d%d%d%d%d",&a, &b, &c, &d, &e))
{
S = 0;
memset(hash, 0, sizeof(hash));
sum = 0;
for(i = -50; i <= 50; i++)
{
if( !i)
continue;
for(j = -50; j <= 50; j++)
{
if(!j)
continue;
sum = a *( i * i * i) + b * ( j * j * j) ;
sum = -sum;
if(sum < 0)
sum += 25000000;
hash[sum]++;
}
}
sum = 0;
for(i = -50; i <= 50; i++)
{
if(!i )
continue;
for(j = -50; j <= 50; j++)
{
if(!j)
continue;
for(k = -50; k <= 50; k++)
{
if(!k )
continue;
sum = c *( i * i * i) + d*( j * j * j) + e* ( k * k * k);
if(sum < 0)
sum += 25000000;
S += hash[sum];
}
}
}
printf("%d\n", S);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: