您的位置:首页 > 运维架构

2016年中国大学生程序设计竞赛(杭州) F Four Operations(暴力枚举)

2016-10-31 10:35 489 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5938

Four Operations

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 243 Accepted Submission(s): 90

Problem Description

Little Ruins is a studious boy, recently he learned the four operations!

Now he want to use four operations to generate a number, he takes a string which only contains digits ‘1’ - ‘9’, and split it into 5 intervals and add the four operations ‘+’, ‘-‘, ‘*’ and ‘/’ in order, then calculate the result(/ used as integer division).

Now please help him to get the largest result.

Input

First line contains an integer T, which indicates the number of test cases.

Every test contains one line with a string only contains digits ‘1’-‘9’.

Limits

1≤T≤105

5≤length of string≤20

Output

For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the result.

Sample Input

1

12345

Sample Output

Case #1: 1

【中文题意】四种运算按加减乘除的顺序组合,然后给你一个数字串,让你把这四种运算符插入这个数字串当中,问你这个表达式最大的值为多少。

【思路分析】枚举减号的位置,然后让后面的被除数尽量的大,然后看前面的加法怎样组合使得前面的值最大,然后进行简单的加减法就行了。

【AC代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long

int main()
{
int t,iCase=0;
char str[23];
scanf("%d",&t);
while(t--)
{
scanf("%s",str+1);
int len=strlen(str);
//printf("%d\n",len);
len--;
LL a,b,c,d,e;
LL maxn=-10000000;
printf("Case #%d: ",++iCase);
for(int i=3;i<=len-2;i++)
{
a=0,b=0,c=0,d=0,e=0;
LL m1,m2;//m1,m2来记录两种情况前面数的和分别为多少,然后取最大值
for(int j=1;j<i-1;j++)
{
a=a*10+str[j]-'0';
}
b=str[i-1]-'0';
//printf("%d\n",b);
m1=a+b;
//printf("%d**\n",m1);
a=0,b=0;
for(int j=2;j<=i-1;j++)
{
b=b*10+str[j]-'0';
}
a=str[1]-'0';
//printf("a%d b%d\n",a,b);
m2=a+b;
//printf("%d**\n",m1);
c=str[i]-'0';
d=str[i+1]-'0';
//printf("%lld %lld\n",c,d);
for(int j=i+2;j<=len;j++)
{
e=e*10+str[j]-'0';
}
//printf("%lld %lld %lld %lld %lld\n",a,b,c,d,e);
maxn=max(maxn,max(m1,m2)-(c*d)/e);
}
printf("%I64d\n",maxn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU
相关文章推荐