您的位置:首页 > 产品设计 > UI/UE

HDU 1947 Rebuilding Roads(树形DP)

2016-10-30 19:42 381 查看
Rebuilding Roads
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%lld & %llu
Submit Status

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is
exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree. 

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P 

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads. 

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated. 

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11


Sample Output

2


Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.] 

题意:给出n,p,一共有n个节点,要求最少减去最少的边是多少,剩下p个节点

思路:典型的树形DP,
dp[s][i]:记录s结点,要得到一棵j个节点的子树去掉的最少边数

 考虑其儿子k

 1)如果不去掉k子树,则

 dp[s][i] = min(dp[s][j]+dp[k][i-j])  0 <= j <= i

 2)如果去掉k子树,则

 dp[s][i] =  dp[s][i]+1

 总的为

 dp[s][i] = min (min(dp[s][j]+dp[k][i-j]) ,  dp[s][i]+1 )

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
using namespace std;
const int N = 610;
const int inf = 0x3f3f3f3f;
int f
, son
, bro
, dp

;
int n, p;
void dfs(int x)
{
for(int i=0;i<=p;i++)
dp[x][i]=inf;
dp[x][1]=0;
int k=son[x];
while(k)
{
dfs(k);
for(int i=p;i>=1;i--)
{
int tmp = dp[x][i]+1;
for(int j=1;j<i;j++)
tmp=min(tmp,dp[x][i-j]+dp[k][j]);
dp[x][i]=tmp;
}
k=bro[k];
}
return ;
}
int solve()
{
int x;
for(int i=1;i<=n;i++)
{
if(!f[i])
{
x=i;
break;
}
}
dfs(x);
int ans=dp[x][p];
for(int i=1;i<=n;i++)
{
if(i==x)
continue;
ans = min(ans,dp[i][p]+1);
}
return ans;
}

int main()
{

while(scanf("%d %d", &n, &p)!=EOF)
{
int x, y;
memset(f,0,sizeof(f));
memset(son,0,sizeof(son));
memset(bro,0,sizeof(bro));
for(int i=1;i<n;i++)
{
scanf("%d %d", &x, &y);
f[y]=1;
bro[y]=son[x];
son[x]=y;
}
printf("%d\n",solve());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: