您的位置:首页 > 其它

Hdu 1520 Anniversary party(树形DP)

2016-10-29 12:14 381 查看


Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9763    Accepted Submission(s): 4178


Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make
the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your
task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127.
After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 

L K 

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 

0 0

 

Output

Output should contain the maximal sum of guests' ratings.

 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

 

Sample Output

5

 

Source

Ural State University
Internal Contest October'2000 Students Session

 

Recommend

linle

/*
Note:
HDU 1520 树状DP
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int n;
int dp[6001][2];
int List[6001][6001];
int Father[6001];

void Link(int s,int f){			//把x连到y的后面
int k=0;
while(List[f][k])	k++;
List[f][k]=s;
}
void tree_dp(int s,int f){
int t,k=0;
while(t=List[s][k++]){
tree_dp(t,s);
dp[s][1] += dp[t][0];
dp[s][0] += max(dp[t][1],dp[t][0]);
}
}
int main(){
int rot;
while(~scanf("%d",&n)){
memset(List,0,sizeof(List));
memset(dp,0,sizeof(dp));

for(int i=1;i<=n;i++)
scanf("%d",&dp[i][1]);
int x,y;
x=y=1;
while(x+y){
scanf("%d%d",&x,&y);
Link(x,y);
Father[x]=y;
}

//还得找个root 好&……%*

for(int i=1;i<=n;i++)
if(Father[i]==0){
rot=i; break;
}
/*
for(int i=1;i<=n;i++)
printf("%d ",Father[i]);
printf("\n"); */
tree_dp(rot,0);
printf("%d\n",max(dp[rot][0],dp[rot][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: