您的位置:首页 > 其它

PAT 1095. Cars on Campus (30)(计算每俩车待的时间)

2016-10-29 10:47 399 查看

官网

题目

1095. Cars on Campus (30)

时间限制

220 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each “in” record is paired with the chronologically next record for the same car provided it is an “out” record. Any “in” records that are not paired with an “out” record are ignored, as are “out” records not paired with an “in” record. It is guaranteed that at least one car is well paired in the input, and no car is both “in” and “out” at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7

JH007BD 18:00:01 in

ZD00001 11:30:08 out

DB8888A 13:00:00 out

ZA3Q625 23:59:50 out

ZA133CH 10:23:00 in

ZD00001 04:09:59 in

JH007BD 05:09:59 in

ZA3Q625 11:42:01 out

JH007BD 05:10:33 in

ZA3Q625 06:30:50 in

JH007BD 12:23:42 out

ZA3Q625 23:55:00 in

JH007BD 12:24:23 out

ZA133CH 17:11:22 out

JH007BD 18:07:01 out

DB8888A 06:30:50 in

05:10:00

06:30:50

11:00:00

12:23:42

14:00:00

18:00:00

23:59:00

Sample Output:

1

4

5

2

1

0

1

JH007BD ZD00001 07:20:09

题目大意

1.给你车辆的进出的时间信息,你要告诉我们在任何特定的时间点停靠在校园里面的车的数量,并且给出一天内停车时间最长的那俩车。

2.n记录的条数,k查询条数。以及record形式:plate_number hh:mm:ss status。in 和out是匹配的,单个的记录无效,查询语句按升序排列。

3.对于每条查询,输出当前校园内总车数,最后一行输出停车时间最长的车牌号码和停车时间,如果不唯一,按字母顺序间隔输出。

解题思路

1.先按时间排好序后,挨个检查,in和out才匹配,out与in不匹配,所以记录每辆车的上个状态即可,然后看与接下来的tag(in or out)是否匹配,匹配的话就把这对状态的时间和车辆信息保存下来,并更新这俩车待的时间。最后不管匹不匹配都更新”上个状态”。

2.把有用的记录保存后然后按时间排序后,in相应的车的数量+1,否则-1。

AC代码

#include<iostream>
#include<cstdio>
#include<string>
#include<vector>
#include<algorithm>
#include<map>
using namespace std;
int n, k;
struct record
{
string name, tag;
int time;
record() {}
record(string _n, int _t, string _tag)
{
this->name = _n;
this->time = _t;
this->tag = _tag;
}
};
bool cmp1(const record &a, const record &b)
{
return a.time < b.time;
}
bool cmp2(string a, string b)
{
return a < b;
}
map<string, record> mp_fomer;
map<string, int> mp_sum;
int max_sum = 0;

int main()
{
cin >> n >> k;
string a, tag;
int h, m, s, sum;
vector<record> records;
for (int i = 0; i < n; i++)
{
cin >> a;
scanf("%d:%d:%d", &h, &m, &s);
cin >> tag;
sum = h * 3600 + m * 60 + s;
records.push_back(record(a, sum, tag));
}
sort(records.begin(), records.end(), cmp1);

//
vector<record> records_update;
vector<string> maxTime_name;
for (int i = 0; i < (int)records.size(); i++)
{
record now = records[i];
if (mp_fomer[now.name].name.empty())
{
mp_fomer[now.name] = now;
}
else
{
//如果in out匹配了,则把他们俩保存,并更新该车辆的总时间
if (mp_fomer[now.name].tag=="in"&&now.tag=="out")
{
records_update.push_back(mp_fomer[now.name]);
records_update.push_back(now);
if (mp_sum[now.name]==0)
{
mp_sum[now.name] = 0;
}
mp_sum[now.name] += (now.time - mp_fomer[now.name].time);
if (mp_sum[now.name]>max_sum)
{
maxTime_name.clear();
max_sum = mp_sum[now.name];
maxTime_name.push_back(now.name);

}
else if (mp_sum[now.name]==max_sum)
{
maxTime_name.push_back(now.name);
}
}
mp_fomer[now.name] = now;
}
}
sort(records_update.begin(), records_update.end(), cmp1);
int currentCar = 0;
int j = 0;
for (int i = 0; i < k; i++)
{
scanf("%d:%d:%d", &h, &m, &s);
sum = h * 3600 + m * 60 + s;
/*cout << "sum:" << sum << endl;
cout << "records_update[j].time:" << records_update[j].time << endl;*/
while (records_update[j].time<=sum&&j<(int)records_update.size())
{
if (records_update[j].tag=="in")
{
currentCar++;
}
else{
currentCar--;
}
j++;

}
cout << currentCar << endl;
}
sort(maxTime_name.begin(), maxTime_name.end(), cmp2);
cout << maxTime_name[0];
for (int i = 1; i < (int)maxTime_name.size(); i++)
{
cout << " " << maxTime_name[i];
}
cout << " ";
h = max_sum / 3600;
max_sum = max_sum % 3600;
m = max_sum / 60;
max_sum = max_sum % 60;
s = max_sum;
printf("%02d:%02d:%02d\n", h, m, s);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: