您的位置:首页 > 编程语言

hdu 5912 Fraction -2016中国大学生程序设计竞赛(长春)

2016-10-28 19:58 507 查看
Fraction

Problem Description
Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:



As a talent, can you figure out the answer correctly?
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n (n≤8).

The second line contains n integers: a1,a2,⋯an(1≤ai≤10).

The third line contains n integers: b1,b2,⋯,bn(1≤bi≤10).
 

Output
For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.
 

Sample Input

1
2
1 1
2 3

 

Sample Output

Case #1: 1 2

Hint
Here are the details for the first sample:
2/(1+3/1) = 1/2

 

题目大意:
题目很明白就是求这个公式化简后的分子分母。


解题思路
手动做一下会发现一直在重复做两个步骤:
① a(x-1)+bx/ax;
②把①得到的分子分母交换后分子*b(x-1)

第②步进行完了后会又得到一个分式,然后会重复上面所述步骤。

所以 一个for循环搞定。
注意 求出的结果要化简。

代码:
#include <cstdio>

int a[10];
int b[10];

int gcd(int a, int b) {
return b ? gcd(b, a % b) : a;
}

int main()
{
int T;
scanf("%d", &T);
for (int t = 1; t <= T; t++) {
int n;
scanf("%d", &n);
for (int i = 1; i <= n; i++) {
scanf("%d", &a[i]);
}
for (int i = 1; i <= n; i++) {
scanf("%d", &b[i]);
}
int fz = b
, fm = a
;
for (int i = n-1; i >= 1; i--) {
fz = a[i] * fm + fz;
int newfm = fz;
fz = b[i] * fm;
fm = newfm;
}

printf("Case #%d: %d %d\n", t, fz / gcd(fz, fm), fm / gcd(fz, fm));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  代码 hdu 思维题
相关文章推荐