您的位置:首页 > 其它

POJ-1611-The Suspects(并查集)

2016-10-28 16:02 357 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K

Total Submissions: 34633 Accepted: 16805

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

题意:多组数据,每组数据第一行给出N和M代表有N个人,接着M行,每行第一行给出n代表随后有n个人为一组,0号视为已感染,与0号直接或者间接在一组的也视为已感染,问0~N-1号人中感染的人数

维护一个并查集,最后查找各个结点的父亲结点即可

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
const int maxn=30005;
const int INF=0x3f3f3f3f;
int Father[maxn];
int Find_Father(int x)
{
if(x!=Father[x])
Father[x]=Find_Father(Father[x]);
return Father[x];
}
int num[maxn];
int main()
{
int N,M;
while(scanf("%d%d",&N,&M)&&N)
{
for(int i=0; i<N; i++)
Father[i]=i;
while(M--)
{
int n;
scanf("%d",&n);
for(int i=0; i<n; i++)
{
scanf("%d",&num[i]);
if(i)
{
int flag_x=Find_Father(num[i-1]);
int flag_y=Find_Father(num[i]);
if(flag_x!=flag_y)
Father[flag_x]=flag_y;
}
}
}
int result=1;
for(int i=1; i<N; i++)
if(Find_Father(0)==Find_Father(i))
result++;
printf("%d\n",result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: