您的位置:首页 > 其它

【POJ 1050】To the Max(dp)

2016-10-27 10:47 411 查看
To the Max

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47334 Accepted: 25060
Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 

As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 

9 2 -6 2 

-4 1 -4 1 

-1 8 0 -2 

is in the lower left corner: 

9 2 

-4 1 

-1 8 

and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output
15

Source

Greater New York 2001
[Submit]   [Go Back]   [Status]  
[Discuss]


Home Page   

Go
Back  

To top

[题意][求最大和子矩阵]
【题解】【dp】
【前缀和乱搞】(这好像是很久之前写过的题。。。复习下)
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[110][110],a[110][110],f1[110],c[110],n,maxn=-0x7fffffff;
int main()
{
int i,j,k;
scanf("%d",&n);
for (i=1;i<=n;i++)
for (j=1;j<=n;j++)
scanf("%d",&a[i][j]);
for (i=1;i<=n;i++)
f[1][i]=a[1][i];
for (i=2;i<=n;i++)
for (j=1;j<=n;j++)
f[i][j]=f[i-1][j]+a[i][j];//每一列的和
for (i=1;i<=n-1;i++)
for (j=i;j<=n;j++)
{
int sum=-0x7fffffff;
for (k=1;k<=n;k++)
c[k]=f[j][k]-f[i][k];//从i到j第k列的和
f1[0]=0;
for (k=1;k<=n;k++)
f1[k]=max(f1[k-1]+c[k],c[k]);
for (k=1;k<=n;k++)
sum=max(sum,f1[k]);//当前情况下的最大值
maxn=max(maxn,sum);//与之前求的最大矩形对比
}
printf("%d",maxn);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp poj