您的位置:首页 > 其它

poj 1787 Charlie's Change(打印路径的多重背包 ->交易数量最大化)

2016-10-26 21:48 627 查看
Charlie's Change
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%lld
& %llu
Submit Status Practice _

Appoint description: 
System Crawler  (Sep 19, 2016 8:51:38 PM)

Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next
task. 

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as
many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly. 

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four
integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie's valet. The last line of the input contains five zeros and no output should be generated for it.

Output

For each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values
Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".

Sample Input

12 5 3 1 2
16 0 0 0 1
0 0 0 0 0


Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.


在输出时要从后向前遍历,因为价值小的可能延伸不到后面,不用担心个数问题因为循环时限制了个数变多时才更新

#include <iostream>

#include <cstdio>

#include <cmath>

#include <cstring>

#include <algorithm>

using namespace std;

const int N = 10010;

int a
, path[10]
, dp
, used
;

int main()

{

    int p;

    int v[]={1,5,10,25};

    while(scanf("%d %d %d %d %d",&p, &a[0], &a[1], &a[2], &a[3]),p||a[0]||a[1]||a[2]||a[3])

    {

        memset(dp,-1,sizeof(dp));

        memset(path,0,sizeof(path));

        dp[0]=0;

        for(int i=0;i<4;i++)

        {

            memset(used,0,sizeof(used));

            for(int j=v[i];j<=N;j++)

            {

                if(dp[j-v[i]]>=0&&dp[j-v[i]]+1>dp[j]&&used[j-v[i]]<a[i])

                {

                     dp[j]=dp[j-v[i]]+1;

                     used[j]=used[j-v[i]]+1;

                     path[i][j]=used[j];

                }

            }

        }

        if(dp[p]>=0)

        {

            int x
={0};

            for(int i=3;i>=0;i--)

            {

                x[i]=path[i][p];

                p-=(x[i]*v[i]);

            }

            printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",x[0], x[1], x[2], x[3]);

        }

        else

        {

            printf("Charlie cannot buy coffee.\n");

        }

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: