您的位置:首页 > 其它

hdu 2639 Bone Collector II(01背包的第k值)

2016-10-26 21:47 417 查看


Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4226    Accepted Submission(s): 2202


Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum
.. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value
of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).

 

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

 

Sample Output

12
2
0

很考验思维,,,因为在过程中保留的数有大有小,又会影响后续的计算,很难将情况分清楚,所以就开一个数组将结果都保留下来,,,

#include <iostream>

#include <cstdio>

#include <cstring>

#include <cmath>

#include <algorithm>

#include <set>

using namespace std;

const int N = 1010;

int dp

, w
, v
, a
, b
;

int main()

{

    int n, m, t, k;

    scanf("%d", &t);

    while(t--)

    {

        scanf("%d %d %d", &n, &m, &k);

        for(int i=0; i<n; i++)

        {

            scanf("%d", &v[i]);

        }

        for(int i=0; i<n; i++)

        {

            scanf("%d", &w[i]);

        }

        memset(dp,0,sizeof(dp));

        for(int i=0; i<n; i++)

        {

            for(int j=m; j>=w[i]; j--)

            {

                for(int p=1;p<=k;p++)

                {

                    a[p]=dp[j-w[i]][p]+v[i];

                    b[p]=dp[j][p];

                }

                a[k+1]=-1, b[k+1]=-1;

                int x=1, y=1;

                for(int p=1;a[x]!=-1||b[y]!=-1;)

                {

                    if(a[x]>b[y])

                    {

                        dp[j][p]=a[x];

                        x++;

                    }

                    else

                    {

                        dp[j][p]=b[y];

                        y++;

                    }

                    if(dp[j][p]!=dp[j][p-1])

                    {

                        p++;

                    }

                    if(dp[j][p]==-1)

                    {

                        dp[j][p]=0;

                        break;

                    }

                }

            }

        }

        printf("%d\n",dp[m][k]);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: