您的位置:首页 > 大数据 > 人工智能

hdu 1022 Train Problem I(简单模拟+栈)

2016-10-26 16:24 363 查看

Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32596 Accepted Submission(s): 12290



[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.







[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.

[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

[align=left]Sample Input[/align]

3 123 321
3 123 312


[align=left]Sample Output[/align]

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".


题目大意:

给你两对序列,问按照第一对序列的入栈顺序怎么安排出栈才能得到第二对序列的出栈顺序,如果可以并给出过程。

例如:4 1234 1234 例子很简单就是1入栈弹栈,2入栈弹栈,3......就得到了第二个序列。

解体思路:

本来一直在想怎样快速判断得到第二对序列的出栈顺序,可是一看要求还要输出过程果断上模拟,结果就AC了。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>

using namespace std;

int main()
{
int n;
int cnt[2*50];
char a[50],b[50];
while(scanf("%d%*c",&n)!=EOF)   //读n,并吃掉n后面的回车
{

//初始化
memset(a, 0, sizeof(a));
memset(b, 0, sizeof(b));
memset(cnt, 0, sizeof(cnt));

//读入第一对序列
for(int i = 0 ; i < n ; i ++)
{
scanf("%c", &a[i]);
}
getchar();  //吃掉第一对序列后面的空格

//读入第二对序列
for(int i = 0 ; i < n ; i ++)
{
scanf("%c", &b[i]);
}
//printf("%s\n%s\n", a, b);

//开辟栈并清空
stack<char> st;
while(!st.empty())
{
st.pop();
}
int pt = 0; //跟踪出栈入栈过程
int i,j;    //控制a,b数组的下标
for(i = 0, j = 0; i < n ; i ++)
{
//每个数字先入栈
st.push(a[i]);
cnt[pt ++] = 1;

//入栈则匹配
while( i<n && !st.empty())
{
if(st.top() == b[j])    //匹配成功弹栈并继续向前匹配
{
st.pop();
cnt[pt ++] = 0;
j ++;
}else{
break;
}
}

}

if(st.empty())  //栈空则说明正好能按照第二对序列出栈
{
printf("Yes.\n");

//根据跟踪过程输出
for(int i = 0 ; i < pt ; i ++)
{
if(cnt[i] == 1)
{
printf("in\n");
}
if(cnt[i] == 0)
{
printf("out\n");
}
}

}else{
printf("No.\n");
}
printf("FINISH\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  模拟