您的位置:首页 > 其它

POJ 3261 Milk Patterns 后缀数组求 一个串种 最长可重复子串重复至少k次

2016-10-25 22:01 417 查看
[b]Milk Patterns[/b]

[b]Description[/b]

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

[b]Input[/b]

Line 1: Two space-separated integers: N and K
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.
Output

Line 1: One integer, the length of the longest pattern which occurs at least K times
[b]Sample Input[/b]

8 2
1
2
3
2
3
2
3
1

[b]Sample Output[/b]

4


记得离散化

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include<vector>
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
#define ls i<<1
#define rs ls | 1
#define mid ((ll+rr)>>1)
#define pii pair<int,int>
#define MP make_pair
typedef long long LL;
const long long INF = 1e18+1LL;
const double Pi = acos(-1.0);
const int N = 2e5+10, M = 2e5+20, mod = 1e9+7, inf = 2e9;

///heght[i] 表示 Suffix(sa[i-1])和Suffix(sa[i]) 的最长公共前缀:
///rank[i] 表示 开头为i的后缀的等级:
///sa[i] 表示 排名为i的后缀 的开头位置:

int *rank,r
,sa
,height
,wa
,wb
,wm
;
bool cmp(int *r,int a,int b,int l) {
return r[a] == r[b] && r[a+l] == r[b+l];
}

void SA(int *r,int *sa,int n,int m) {
int *x=wa,*y=wb,*t;
for(int i=0;i<m;++i)wm[i]=0;
for(int i=0;i<n;++i)wm[x[i]=r[i]]++;
for(int i=1;i<m;++i)wm[i]+=wm[i-1];
for(int i=n-1;i>=0;--i)sa[--wm[x[i]]]=i;
for(int i=0,j=1,p=0;p<n;j=j*2,m=p){
for(p=0,i=n-j;i<n;++i)y[p++]=i;
for(i=0;i<n;++i)if(sa[i]>=j)y[p++]=sa[i]-j;
for(i=0;i<m;++i)wm[i]=0;
for(i=0;i<n;++i)wm[x[y[i]]]++;
for(i=1;i<m;++i)wm[i]+=wm[i-1];
for(i=n-1;i>=0;--i)sa[--wm[x[y[i]]]]=y[i];
for(t=x,x=y,y=t,i=p=1,x[sa[0]]=0;i<n;++i) {
x[sa[i]]=cmp(y,sa[i],sa[i-1],j)?p-1:p++;
}
}
rank=x;
}
void Height(int *r,int *sa,int n) {
for(int i=0,j=0,k=0;i<n;height[rank[i++]]=k)
for(k?--k:0,j=sa[rank[i]-1];r[i+k] == r[j+k];++k);
}

int n,a
,k;
int check(int x) {
int i = 2,cnt;
while(1) {
while(i <= n && height[i] < x) i++;
if(i > n) break;
cnt = 1;
while(i <= n && height[i] >= x) {
cnt++;
i++;
}
if(cnt >= k) {
return 1;
}
}
return 0;
}
int main() {
while(~scanf("%d%d",&n,&k)) {
for(int i = 1; i <= n; ++i) scanf("%d",&a[i]),r[i-1] = a[i];
sort(a+1,a+n+1);
int c = unique(a+1,a+n+1) - a - 1;
for(int i = 0; i < n; ++i) r[i] = lower_bound(a+1,a+c+1,r[i]) - a;
r
= 0;
SA(r,sa,n+1,20001);
Height(r,sa,n);
int ll = 1, rr = n,ans = 0;
while(ll <= rr) {
int md = (ll + rr) >> 1;
if(check(md)) {
ans = md, ll = md + 1;
} else rr = md - 1;
}
printf("%d\n",ans);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐