您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树五:层序遍历(队列)

2016-10-25 20:36 302 查看


数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。


Input

输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。


Output

输出二叉树的层次遍历序列。


Example Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,



Example Output

abcdefg
xnuli

#include<stdio.h>
struct node
{
int data;
struct node *l,*r;
};
char s[1110];
struct node *p[1110];
int cnt;
struct node *creat()
{
struct node*t;
if(s[++cnt]==',')
{
t=NULL;
}
else
{
t= new node;
t->data=s[cnt];
t->l=creat();
t->r=creat();
}
return t;
};
void cenci(struct node *root)
{
int tail=0,head=0;
p[tail++] = root;
while(tail>head)
{
if(p[head])
{
printf("%c",p[head]->data);
p[tail++]=p[head]->l;
p[tail++]=p[head]->r;
}
head++;
}

}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
cnt=-1;
scanf("%s",s);
struct node* root;
root = creat();
cenci(root);
printf("\n");

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: