您的位置:首页 > 产品设计 > UI/UE

HDU 1509 Windows Message Queue(优先队列)

2016-10-25 20:08 417 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1509

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5692 Accepted Submission(s): 2286

Problem Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.

Sample Input

GET

PUT msg1 10 5

PUT msg2 10 4

GET

GET

GET

Sample Output

EMPTY QUEUE!

msg2 10

msg1 10

EMPTY QUEUE!

Author

ZHOU, Ran

【题目分析】先按优先级排序,优先级相同的按大小排序。

【AC代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

struct node
{
char message[105];
int num;
int priority;
int n;
bool operator < (const node a)const
{
if(a.priority==priority)
{
return num>a.num;
}
else
{
return priority>a.priority;
}
}
}a;

int main()
{
char op[10];
int sum=0;
priority_queue<node>pq;
while(~scanf("%s",op))
{
if(strcmp(op,"GET")==0)
{
if(!pq.empty())
{
printf("%s %d\n",pq.top().message,pq.top().n);
pq.pop();
}
else
{
printf("EMPTY QUEUE!\n");
}
}
else
{
sum++;
a.num=sum;
scanf("%s%d%d",&a.message,&a.n,&a.priority);
pq.push(a);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU