您的位置:首页 > 其它

POJ 3666 Making the Grade(DP 推导)

2016-10-25 19:45 417 查看
Making the Grade

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6416 Accepted: 2983
Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add
and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting
at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove
dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + ... + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9

Sample Output
3
dp[i][j]  表示i与j换值得到的最小花费

#include <iostream>

#include <cstdio>

#include <cstring>

#include <algorithm>

#include <cmath>

#include <climits>

using namespace std;

typedef long long LL;

const int N = 2010;

typedef long long LL;

LL dp

, a
, b
;

LL solve();

int n;

int cmp(LL x,LL y)

{

    return x>y;

}

int main()

{

    while(scanf("%d", &n)!=EOF)

    {

        for(int i=1; i<=n; i++)

        {

            scanf("%lld", &a[i]);

            b[i]=a[i];

        }

        LL ans=INT_MAX;

        sort(b+1,b+n+1);

        ans=ans<solve()?ans:solve();

        sort(b+1,b+n+1,cmp);

        ans=ans<solve()?ans:solve();

        printf("%lld\n",ans);

        return 0;

    }

}

LL solve()

{

    memset(dp,0,sizeof(dp));

    LL ans=INT_MAX;

    for(int i=1; i<=n; i++)

    {

        LL tmp=dp[i-1][1];

        for(int j=1; j<=n; j++)

        {

            tmp=min(tmp,dp[i-1][j]);

            LL x=a[i]-b[j];

            if(x<0)

            x=-x;

            dp[i][j]=tmp+x;

        }

    }

    for(int i=1; i<=n; i++)

    {

        ans=ans<dp
[i]?ans:dp
[i];

    }

    return ans;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: