您的位置:首页 > 其它

[UVA11300][智商题]Spreading the Wealth

2016-10-25 17:30 281 查看
A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone

around a circular table. First, everyone has converted all of their properties to coins of equal value,

such that the total number of coins is divisible by the number of people in the village. Finally, each

person gives a number of coins to the person on his right and a number coins to the person on his left,

such that in the end, everyone has the same number of coins. Given the number of coins of each person,

compute the minimum number of coins that must be transferred using this method so that everyone

has the same number of coins.

Input

There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the

village. n lines follow, giving the number of coins of each person in the village, in counterclockwise

order around the table. The total number of coins will t inside an unsigned 64 bit integer.

Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3

100

100

100

4

1

2

5

4

Sample Output

0

4

首先ORZ LRJ

OI中常用的一个思维, 1给2x枚金币等效于2给1-x枚金币,所以我们只考虑n->n-1,n-1->n-2……1->n

令xi为i给i-1的金币数量,假设i初始有Ai枚金币,且最终要达到M,容易得出方程,Ai-xi+xi+1=M,再规定C1=A1-M,C2=C1+A2-M,则xi+1=x1-Ci

目标为求|x1|+|x1-C1|+……|x1-Cn-1|的最小值,回归到几何意义,就是在数轴上已知一些点,找出一个点到这些点距离和最小

不难证明出这些点的中位数是满足的,证明详见蓝书P6,那问题就可以圆满解决了

不知为何自动读入的AUTO在UVA上要RE

#include<cstdio>
#include<algorithm>
/*#ifdef WIN32
#define AUTO "%I64d"
#else
#defein AUTO "%lld"
#endif*/
using namespace std;
const int maxn=1e6+5;
#define LL long long
LL A[maxn],C[maxn],tot,M,n;
int main()
{
//  freopen("ant.in","r",stdin);
while (scanf("%d",&n)==1)
{
tot=0;
for (int i=1;i<=n;i++) scanf("%lld",&A[i]),tot+=A[i];
M=tot/n;
C[0]=0;
for (int i=1;i<n;i++) C[i]=C[i-1]+A[i]-M;
sort(C,C+n);
LL x1=C[n>>1],ans=0;
for (int i=0;i<n;i++) ans+=abs(x1-C[i]);
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: