您的位置:首页 > 编程语言 > C语言/C++

洛谷 P2850 [USACO06DEC] 虫洞Wormholes

2016-10-25 16:28 204 查看


题目描述

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises
N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

John在他的农场中闲逛时发现了许多虫洞。虫洞可以看作一条十分奇特的有向边,并可以使你返回到过去的一个时刻(相对你进入虫洞之前)。John的每个农场有M条小路(无向边)连接着N (从1..N标号)块地,并有W个虫洞。其中1<=N<=500,1<=M<=2500,1<=W<=200。 现在John想借助这些虫洞来回到过去(出发时刻之前),请你告诉他能办到吗。 John将向你提供F(1<=F<=5)个农场的地图。没有小路会耗费你超过10000秒的时间,当然也没有虫洞回帮你回到超过10000秒以前。


输入输出格式

输入格式:

Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N, M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

输出格式:

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).


输入输出样例

输入样例#1:
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8


输出样例#1:
NO
YES





















说明

For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

SPFA判负环~

今天果然大凶,因为输入错误检查了一节课……快要崩溃了……可是样例居然能过……

裸的判负环,经过次数大于n时,输出yes即可。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;

int T,n,m,W,s,e,t,fi[10001],ne[10001],w[10001],v[10001],cnt,num[10001],tot[10001];
bool b[10001];

void add(int u,int vv,int val)
{
w[++cnt]=vv;ne[cnt]=fi[u];fi[u]=cnt;v[cnt]=val;
}

void cal()
{
for(int i=1;i<=n;i++) num[i]=999999999;
queue<int> q;q.push(1);b[1]=1;num[1]=0;tot[1]=1;
while(!q.empty())
{
int k=q.front();q.pop();b[k]=0;
if(tot[k]>n)
{
printf("YES\n");return;
}
for(int j=fi[k];j;j=ne[j])
if(num[w[j]]>v[j]+num[k])
{
num[w[j]]=v[j]+num[k];
if(!b[w[j]])
{
q.push(w[j]);b[w[j]]=1;tot[w[j]]++;
}
}
}
printf("NO\n");
}

int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&m,&W);
memset(fi,0,sizeof(fi));
memset(tot,0,sizeof(tot));
memset(b,0,sizeof(b));cnt=0;
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&s,&e,&t);
add(s,e,t);add(e,s,t);
}
for(int i=1;i<=W;i++)
{
scanf("%d%d%d",&s,&e,&t);
add(s,e,-t);
}
cal();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ SPFA