您的位置:首页 > 其它

poj---1751 Highways

2016-10-24 23:15 323 查看
Highways

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12946 Accepted: 3738 Special Judge
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns.
However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus
their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length.
Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from
1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a
highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by
a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output
1 6
3 7
4 9
5 7
8 3

题目大意:

给出n个城镇的坐标(x,y),要在这n个城镇间建公路,已知有m条公路已经建好,求还需建多少条公路,输出还需建的公路两端的村庄。
即寻找最小生成树。

思路:

用Kruskal算法会超时,所以用Prim算法求解。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

struct tt {
    int x, y;
}town[760];

int g[760][760];
int n, m;

void Distance() {
    for (int i = 1; i < n; i++) {
        for (int j = i + 1; j <= n; j++) {
            g[i][j] = g[j][i] = ((town[i].x - town[j].x)*(town[i].x - town[j].x) + (town[i].y - town[j].y)*(town[i].y - town[j].y));//两点间距离
        }
    }
}

void prim() {
    int i, j, k, maxcost = 999999999, min;
    int dist[760], pre[760];
    bool vis[760];
    memset(vis, true, sizeof(vis));
    for (i = 1; i <= n; i++)
    {
        dist[i] = maxcost;
        pre[i] = 1;
    }
    vis[1] = false;
    dist[1] = 0;
    for (i = 1; i <= n; i++)
    {
        min = maxcost;
        k = 1;
        for (j = 1; j <= n; j++)
            if (vis[j] && dist[j]<min)
            {
                k = j;    
                min = dist[j];
            }
        vis[k] = false;
        for (j = 1; j <= n; j++)
            if (dist[j]>g[k][j] && vis[j])
            {
                dist[j] = g[k][j];    
                pre[j] = k;
            }
    }
    for (i = 2; i <= n; i++)
    {
        if (g[pre[i]][i] != 0)
        {
            printf("%d %d\n", i, pre[i]);
        }
    }
}

int main() {
    int x, y;
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%d%d", &town[i].x, &town[i].y);
    }
    Distance();//求两点之间的距离
    scanf("%d", &m);
    for(int i = 1; i <= m; i++) {
        scanf("%d%d", &x, &y);
        g[x][y] = g[y][x] = 0;//已经建好的公路赋值为0
    }
    prim();
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  最小生成树