您的位置:首页 > 其它

POJ 2240 Arbitrage(最短路)

2016-10-23 23:03 459 查看
Arbitrage

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No

题目大意:找相乘以后权值为正的环
解题思路:数据量比较小,可以用Floyd;利用map保存每个国家货币的编号

代码如下:

#include <cstdio>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;

const int maxn = 33;
double dp[maxn][maxn];
int n,m;
map<string,int> mp;
void init()
{
for(int i = 0;i < n;i++){
for(int j = 0;j < n;j++){
dp[i][j] = (i == j);
}
}
mp.clear();
}

void floyd()
{
for(int k = 0;k < n;k++){
for(int i = 0;i < n;i++){
for(int j = 0;j < n;j++){
dp[i][j] = max(dp[i][j],dp[i][k] * dp[k][j]);
}
}
}

// for(int i = 0;i < n;i++){
// for(int j = 0;j < n;j++){
// cout << dp[i][j] << ' ';
// }
// cout << endl;
// }
}

int main(void)
{
string s1,s2;
double d;
int ncase = 0;
while(cin >> n && n){
int cnt = 0;
init();
for(int i = 0;i < n;i++){
cin >> s1;
if(!mp[s1]) mp[s1] = cnt++;
}
cin >> m;
while(m--){
cin >> s1 >> d >> s2;
dp[mp[s1]][mp[s2]] = d;
}
floyd();
bool flag = 0;
for(int i = 0;i < n;i++){
for(int j = 0;j < n;j++){
if(dp[i][j] * dp[j][i] > 1){
flag = 1;
break;
}
}
}
printf("Case %d: %s\n",++ncase,flag ? "Yes" : "No");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ