您的位置:首页 > 其它

**View Angle

2016-10-23 20:37 253 查看
View Angle

Crawling in process...
Crawling failed
Time Limit:2000MS    
Memory Limit:262144KB    
64bit IO Format:
%I64d & %I64u

Submit

Status
Practice
CodeForces 257C


uDebug

Description

Input

Output

Sample Input

Sample Output

Hint

Description

Flatland has recently introduced a new type of an eye check for the driver's licence. The check goes like that: there is a plane with mannequins standing on it. You should tell the value of the minimum angle with the vertex at the origin of coordinates and
with all mannequins standing inside or on the boarder of this angle.

As you spend lots of time "glued to the screen", your vision is impaired. So you have to write a program that will pass the check for you.

Input

The first line contains a single integer n (1 ≤ n ≤ 105) — the number of mannequins.

Next n lines contain two space-separated integers each:
xi, yi (|xi|, |yi| ≤ 1000)
— the coordinates of the i-th mannequin. It is guaranteed that the origin of the coordinates has no mannequin. It is guaranteed that no two mannequins are located in the same point on the plane.

Output

Print a single real number — the value of the sought angle in degrees. The answer will be considered valid if the relative or absolute error doesn't exceed
10 - 6.

Sample Input

Input
2
2 0
0 2


Output
90.0000000000


Input
3
2 0
0 2
-2 2


Output
135.0000000000


Input
4
2 0
0 2
-2 0
0 -2


Output
270.0000000000


Input
2
2 1
1 2


Output
36.8698976458


Sample Output

Hint

Solution for the first sample test is shown below:



Solution for the second sample test is shown below:



Solution for the third sample test is shown below:



Solution for the fourth sample test is shown below:



找相邻点间最大的角

#include<stdio.h>
#include<math.h>
#include<algorithm>
#define M acos(-1.0)
using namespace std;
struct dian
{
double x;
double y;
double angle;
}p[100001];

bool cmp(dian a,dian b)
{
return a.angle<b.angle;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n; i++)
{
scanf("%lf%lf",&p[i].x,&p[i].y);
p[i].angle=atan2(p[i].y,p[i].x);
}
sort(p,p+n,cmp);
p
.angle=p[0].angle+2*M;
double ans=2*M;
for(int i=0;i<n;i++)
{
ans=min(2*M-fabs(p[i+1].angle-p[i].angle),ans);
}
printf("%lf\n",ans*180.0/M);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: