您的位置:首页 > 其它

poj 3461 KMP

2016-10-23 14:57 232 查看
Oulipo
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 43263Accepted: 17413
DescriptionThe French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. InputThe first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. OutputFor every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. Sample Input3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output1
3
0Source

#include <iostream>
#include <cstdio>
#include<limits>
#include <map>
#include <cstring>
#include <string>
#include <cstdlib>

using namespace std;

const int N = 1000005;
char patter[10005], origin[N];
int Next[10005];

void getnext()
{
int i, j;

int len = strlen(patter);

Next[0]=-1;
j=-1;
i=0;
while(i<len)
{
if(j==-1||patter[i]==patter[j])
{
Next[++i]=++j;
}
else
{
j = Next[j];
}
}
}

int kmp()
{
int i, j;

int patterlen = strlen(patter);
int originlen = strlen(origin);

i = 0, j=0;
int ans = 0;

while(i<originlen)
{
if(j==-1||patter[j]==origin[i])
{
i++;
j++;
}
else
j = Next[j];

if(j==patterlen)
{
ans++;
}
}
return ans;
}

int main()
{
int t;

scanf("%d", &t);

while(t--)
{
scanf("%s %s", patter, origin);
getnext();
printf("%d\n", kmp());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: