您的位置:首页 > 其它

HDU 1009 FatMouse' Trade 解题报告

2016-10-22 23:02 471 查看
Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000. 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output

13.333
31.500


       用猫粮换豆子,有M磅的猫粮与N个的可以换豆子的房间。每个房间都有各自的兑换方式和豆子储量。因为在每个房间,都可以只兑换该房间豆子总量的一部分,因此自然先去汇率最高的房间兑换,如果全部兑换完这个房间的豆子还有猫粮剩余,就去剩下的房间中汇率最高的房间接着兑换;如果猫粮不足以兑换完这个房间的豆子,或者全部兑换完豆子正好耗尽猫粮,自然就是能兑换多少兑多少,然后停止交易。因此在执行这一流程前,根据汇率大小将所有房间进行排序。

#include <iostream>
#include <algorithm>
using namespace std;

struct bean
{
double j,f;
}b[1005];

int cmp(bean a,bean b)
{
return a.j/a.f > b.j/b.f;
}

int main()
{
int m,n;
while(~scanf("%d%d",&m,&n)&&m>=0)
{
double sum=0;
for(int i=0;i<n;i++)
scanf("%lf%lf",&b[i].j,&b[i].f);
sort(b,b+n,cmp);
for(int i=0;i<n;i++)
{
if(m>b[i].f)
{
sum+=b[i].j;
m-=b[i].f;
}
else
{
sum+=(m/b[i].f)*b[i].j;
break;
}
}
printf("%.3f\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息