您的位置:首页 > 其它

hdu1892 See you~ 二维树状数组

2016-10-22 22:42 429 查看


首先,这个时二维数组数组的用法。。。

直接套模版的说。。。


See you~

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 4813 Accepted Submission(s): 1537



Problem Description

Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World
Finals last year.

When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work
is to tell me how many books are stayed in some rectangles.

To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position
or bring in one book and put it on one position.

Input

In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.

For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.

There are 4 kind of queries, sum, add, delete and move.

For example:

S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.

A x1 y1 n1 means I put n1 books on the position (x1,y1)

D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.

M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.

Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output

At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.

For each "S" query, just print out the total number of books in that area.

Sample Input

2
3
S 1 1 1 1
A 1 1 2
S 1 1 1 1
3
S 1 1 1 1
A 1 1 2
S 1 1 1 2


Sample Output

Case 1:
1
3
Case 2:
1
4


Author

Sempr|CrazyBird|hust07p43

Source

HDU 2008-4 Programming Contest

感觉题目没有讲清楚啊。。。每个格子上面初始是有一本书的

刚刚读题的我还以为是二维的线段树。。。。然而二维的线段数仿佛并不是用来求这玩意儿的。。。。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int save[maxn+10][maxn+10];
int lowbit(int x) {
return x & (-x);
}
void update(int x,int y, int val) {
for(int i = x; i <= maxn; i += lowbit(i)) {
for(int j = y; j <= maxn; j += lowbit(j)) {
save[i][j] += val;
}
}
}
int query(int x, int y) {
int sum = 0;
for(int i = x; i > 0; i -= lowbit(i)) {
for(int j = y; j > 0; j -= lowbit(j)) {
sum += save[i][j];
}
}
return sum;
}
int getSingle(int x, int y) {
return query(x, y) + query(x-1, y-1) - query(x-1, y) - query(x, y-1);
}
int main(){
int t,q,i,j;
scanf("%d",&t);
int rnd=1;
while(t--){
printf("Case %d:\n",rnd);
rnd++;
memset(save, 0, sizeof(save));
for(i = 1; i <= maxn; i++) {
for(j = 1; j <= maxn; j++) {
update(i, j, 1);
}
}
scanf("%d",&q);
char in;
int x1,x2,y1,y2,n;
for(i=1;i<=q;i++){
cin>>in;
if(in=='S'){
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
if(x1>x2){
swap(x1,x2);
}
if(y1>y2){
swap(y1, y2);
}
printf("%d\n",query(x2+1, y2+1) - query(x1, y2+1) - query(x2+1, y1) + query(x1, y1));
}else if(in == 'A'){
scanf("%d%d%d",&x1,&y1,&n);
update(x1+1, y1+1, n);
}else if(in == 'D'){
scanf("%d%d%d", &x1, &y1, &n);
int now = getSingle(x1+1, y1+1);
n = min(n, now);
update(x1+1, y1+1, -n);
}else{
scanf("%d%d%d%d%d", &x1, &y1, &x2, &y2, &n);
int n1 = getSingle(x1+1, y1+1);
n = min(n, n1);
update(x1+1, y1+1, -n);
update(x2+1, y2+1, n);
}
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: