您的位置:首页 > 产品设计 > UI/UE

HDU 5918 Sequence I【KMP?】【2016中国大学生程序设计竞赛(长春)】

2016-10-22 15:38 471 查看


Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1102    Accepted Submission(s): 421


Problem Description

Mr. Frog has two sequences a1,a2,⋯,an and b1,b2,⋯,bm and
a number p. He wants to know the number of positions q such that sequence b1,b2,⋯,bm is
exactly the sequence aq,aq+p,aq+2p,⋯,aq+(m−1)p where q+(m−1)p≤n and q≥1.

 

Input

The first line contains only one integer T≤100,
which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1≤n≤106,1≤m≤106 and 1≤p≤106.

The second line contains n integers a1,a2,⋯,an(1≤ai≤109).

the third line contains m integers b1,b2,⋯,bm(1≤bi≤109).

 

Output

For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.

 

Sample Input

2
6 3 1
1 2 3 1 2 3
1 2 3
6 3 2
1 3 2 2 3 1
1 2 3

 

Sample Output

Case #1: 2
Case #2: 1

 

Source

2016中国大学生程序设计竞赛(长春)-重现赛

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=5918

题意:给定序列
aa
、序列
bb
和一个整数
pp
,要求出有多少个
qq
使得
b_1,b_2,\ldots,b_mb​1​​,b​2​​,…,b​m​​
恰好是
a_q,a_{q+p},\ldots,a_{q+(m-1)p}a​q​​,a​q+p​​,…,a​q+(m−1)p​​


题解:将
aa
按照 
\mathrm{mod}\
pmod p
拆成若干个串,分别做一次
KMP.

其实可以不用KMP。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn=1e6+5;
int a[maxn];
int b[maxn];
int Next[maxn];
int n,m,p;
/**
void getNext()
{
int i=0,j=-1;
Next[0]=-1;
while(i<m)
{
if(j==-1||b[i]==b[j])
{
i++,j++;
Next[i]=j;
}
else
j=Next[j];
}
}
*/
int KMP(int x)
{
int i=x,j=0;
while(i<n)
{
if(a[i]==b[j])
i+=p,j++;
else
return 0;
if(j==m)
return 1;
}
return 0;
}
int main()
{
int T,kase=0;
//freopen("data/5918.txt","r",stdin);
cin>>T;
while(T--)
{
cin>>n>>m>>p;
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
for(int i=0; i<m; i++)
scanf("%d",&b[i]);
//getNext();
int ans=0;
for(int i=0; i+p*(m-1)<n; i++)
{
ans+=KMP(i);
}
printf("Case #%d: %d\n",++kase,ans);
}
return 0;
}

尊重原创,转载请注明出处:http://blog.csdn.net/hurmishine
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
相关文章推荐