您的位置:首页 > 其它

hdu1160_FatMouse's Speed 最大上升子序列

2016-10-21 21:55 387 查看


FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768
K (Java/Others)
Total Submission(s): 14806    Accepted Submission(s): 6521
Special Judge

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information
for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 

 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m
then it must
be the case that 

W[m[1]] < W[m[2]] < ... < W[m
]

and 

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

 

Sample Output

4
4
5
9
7

 
题意:给你1e4只老鼠体重 Wi 和奔跑的速度 Si ,让你算出一个最长的序列,Wi 越大 Si 越小。
思路:最大上升子序列,先按Wi sort一下,然后LIS,最后dfs输出该序列。n为1e4,所以不用LIS优化,还是比较好做的。
#include<bits/stdc++.h>
using namespace std;

struct K{
int w;
int s;
int num;
}mice[10050];

int pre[10050];
int dp[10050];

int dfs(int i){
int num = mice[i].num;
if(i != pre[i])
dfs(pre[i]);
printf("%d\n",num);
}

bool cmp(K a, K b){
if(a.w != b.w)
return a.w < b.w;
else
return a.s < b.s;
}

int main(){

int n = 0;
int w,s;
while(scanf("%d%d",&w,&s) != EOF){
n++;
mice
.w = w;
mice
.s = s;
mice
.num = n;
}
sort(mice+1,mice+1+n,cmp);
pre[1] = 1;
dp[1] = 1;
for(int i = 2; i <= n; i++){
int maxx = 0;
int maxi = i;
for(int j = i-1; j >= 1; j--){
if(mice[i].s < mice[j].s){
if(dp[j] > maxx){
maxx = dp[j];
maxi = j;
}
}
}
dp[i] = maxx+1;
pre[i] = maxi;
}

int maxx = 0;
int maxi;
for(int i = 1; i <= n; i++){
if(maxx < dp[i]){
maxx = dp[i];
maxi = i;
}
}
cout << maxx <<endl;
dfs(maxi);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: