您的位置:首页 > 其它

POJ 2230 Watchcow 欧拉回路

2016-10-20 11:19 477 查看
Watchcow
Time Limit: 3000MS      Memory Limit: 65536K
Total Submissions: 7581     Accepted: 3321      Special Judge

Description
Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input
* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint
OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source
USACO 2005 January Silver


#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

const int N=10000+3;
const int M=50000+3;

struct edge{
int to;
int index;
};

vector<edge>G
;
int ans[2*M+1];
int ansi=0;
bool used[2*M];

void EulerCircuit(int now){
for(int i=0;i<G[now].size();++i){
int index=G[now][i].index;
int to=G[now][i].to;
if(!used[index]){
used[index]=true;
EulerCircuit(to);
ans[ansi++]=now;
}
}
}

int main()
{
//freopen("/home/lu/文档/r.txt","r",stdin);
//freopen("/home/lu/文档/w.txt","w",stdout);
int n,m;
scanf("%d%d",&n,&m);
int u,v;
for(int i=0;i<m;++i){
scanf("%d%d",&u,&v);
G[u].push_back({v,2*i});
G[v].push_back({u,2*i+1});
}
EulerCircuit(1);
printf("1\n");
for(int i=0;i<ansi;++i)
printf("%d\n",ans[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 欧拉回路 图论