您的位置:首页 > 其它

hdu2266 How Many Equations Can You Find

2016-10-18 17:26 239 查看
Description

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3

21 1

Sample Output

18

1

方法:搜素 递归

#include<stdio.h>
#include<string.h>
using namespace std;
__int64 n,sum;
char a[13];
int len;
void dfs(__int64 x,__int64 num)
{
if(x==len)
{
if(num==n)
sum++;
return ;
}
__int64 k=0;
for(int i=x;i<len;i++)
{
k=k*10+(a[i]-'0');
dfs(i+1,num+k);
if(x)
dfs(i+1,num-k);
}
}

int main()
{
while(~scanf("%s%I64d",a,&n))
{
len=strlen(a);
sum=0;
dfs(0,0);
printf("%I64d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: