您的位置:首页 > 其它

codeforces 237c-Primes on Interva

2016-10-18 16:17 295 查看
Primes on Interva

lCrawling in process...Crawling failedTime
Limit:
1000MS    Memory Limit:262144KB    
64bit IO Format:%I64d & %I64u

SubmitStatus

Description

Input

Output

Sample Input

Sample Output

Hint

Description

You've decided to carry out a survey in the theory of prime numbers. Let us remind you that a prime number is a positive integer that has exactly two distinct positive integer divisors.

Consider positive integers a,
a + 1, ...,
b (a ≤ b). You want to find the minimum integerl
(1 ≤ l ≤ b - a + 1) such that for any integerx
(a ≤ x ≤ b - l + 1) amongl integers
x,x + 1,
..., x + l - 1 there are at least
k prime numbers.

Find and print the required minimum l. If no valuel meets the described limitations, print -1.

Input

A single line contains three space-separated integers a, b, k (1 ≤ a, b, k ≤ 106; a ≤ b).

Output

In a single line print a single integer — the required minimum
l. If there's no solution, print -1.

Sample Input

Input
2 4 2


Output
3


Input
6 13 1


Output
4


Input
1 4 3


Output
-1


题意:你一个闭区间[a,b],求一个最小的L,使得在区间[a,b-L+1]内任取一个数x,
//可以满足在x,x+1,x+2,……,x+L-2,x+L-1内至少包含k个素数。(1<=a,b,k<=10^6)

#include <stdio.h>
#include <string.h>
int num[1000011], a, b, k;
int s[1000000+11]={1,1};
void su()//筛选素数并计算素数个数
{
for(int i = 2; i<1000011; i++){
num[i] = num[i-1];
if(s[i])
continue;
else num[i]++;//计算素数个数
for(int j=2*i; j<1000011; j+=i)
s[j] = 1;
}
}
int pan(int mid){//二分查找
for(int i = a; i <= b-mid+1; i++){
if(num[i+mid-1] - num[i-1] < k)
return 0;
}
return 1;
}
int main(){
su();
scanf("%d%d%d", &a, &b, &k);
if(num[b] - num[a-1] < k){
printf("-1\n");
return 0;
}
int l = 1, r = b-a+1, t;
while(r>=l){
int mid = (l+r)/2;
if(pan(mid))
t= mid, r = mid-1;
else
l = mid+1;
}
printf("%d\n", t);
}


#include<cstdio>
//#include<algorithm>
//using namespace std;
int a,b,k,num[1000011];
int s[1000000+11]={1,1};
void su()
{
for(int i=2;i<=1000011;i++)
{
num[i]=num[i-1];
if(s[i]==1)continue;
else num[i]++;
for(int j=2*i;j<=1000011;j+=i)
s[j]=1;
}
}
int pan(int l)
{
for(int i=a;i<=b-l+1;i++)
{
if(num[i+l-1]-num[i-1]<k)
return 0;
}
return 1;
}
int main()
{
su();
scanf("%d%d%d",&a,&b,&k);
if(num[b]-num[a-1]<k)
printf("-1\n");
else
{
int l=1,r=b-a+1,t;
while(l<=r)
{
int mid=(l+r)/2;
if(pan(mid))
t=mid,r=mid-1;
else
l=mid+1;
}
printf("%d\n",t);
}
return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: