您的位置:首页 > 其它

hdu 2602 Bone Collector (0-1)

2016-10-16 22:36 190 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 52811    Accepted Submission(s): 22241

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , eac
4000
h case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 

Author

Teddy

 

Source

HDU 1st “Vegetable-Birds Cup” Programming
Open Contest

 

Recommend

lcy

 

Statistic | Submit | Discuss | Note

题目大意:骨头收集者去古墓收集骨头,带一个容量为V的背包,求在背包容量允许的情况下,求价值最大,每一个骨头对应一个价值

解析:简单的 0-1 背包,直接循环一下就好了

代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 1009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

int dp
, a
, b
;

int main()
{
int v, n, t, i, j;
cin >> t;
while(t--)
{
scanf("%d%d", &n, &v);
for(i = 1; i <= n; i++) scanf("%d", &a[i]);
for(i = 1; i <= n; i++) scanf("%d", &b[i]);
memset(dp, 0, sizeof(dp));
for(i = 1; i <= n; i++)
{
for(j = v; j >= b[i]; j--)
{
dp[j] = max(dp[j], dp[j - b[i]] + a[i]);
}
}
printf("%d\n", dp[v]);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: