您的位置:首页 > 其它

hdu3336 Count the string (KMP)

2016-10-16 18:44 399 查看

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab


Sample Output

6


Author

foreverlin@HNU

Source

HDOJ Monthly Contest – 2010.03.06

题意:给一串字符串,问这串字符串所有的前缀总共在这个字符串中出现了几次。

思路:

设ans[i]:以string[i]结尾的子串总共含前缀的数量

所以ans[j]=ans[nex[j]]+1,即以j结尾的子串中含前缀的数量加上前j个字符这一前缀;

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n;
char c[200005];
int nex[200005];
void getnext()
{
int i=0,j=-1;
nex[0]=-1;
while(c[i])
{
if(j==-1||c[i]==c[j])
nex[++i]=++j;
else
j=nex[j];
}
}
int main()
{
int t;
scanf("%d",&t);
int ans[200005];
while(t--)
{
scanf("%d",&n);
scanf("%s",c);
getnext();
ans[0]=0;
int s=0;
for(int i=1;i<=n;i++)
{
ans[i]=ans[nex[i]]+1;
s=(s+ans[i])%10007;
}
printf("%d\n",s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: