您的位置:首页 > 移动开发

HDU-2830-Matrix Swapping II(DP)

2016-10-15 19:18 465 查看
Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1804 Accepted Submission(s): 1199

Problem Description

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output

Output one line for each test case, indicating the maximum possible goodness.

Sample Input

3 4

1011

1001

0001

3 4

1010

1001

0001

Sample Output

4

2

题意:给出N*M的01矩阵,求出任意交换列后全是1的最大矩阵面积

戳这里看这题的简易版

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=1005;
int DP[maxn][maxn];//以(i,j)为底的高度
bool cmp(int x,int y)
{
return x>y;
}
int main()
{
int N,M;
int flag[maxn];//临时性数组
char str[maxn];
while(~scanf("%d%d",&N,&M))
{
for(int i=0; i<=N; i++)
for(int j=0; j<=M; j++)
DP[i][j]=0;
int result=0;
for(int i=1; i<=N; i++)
{
scanf("%s",str+1);
for(int j=1; j<=M; j++)
{
str[j]=='0'?DP[i][j]=0:DP[i][j]=DP[i-1][j]+1;
flag[j]=DP[i][j];
str[j]='\0';
}
sort(flag+1,flag+M+1,cmp);
for(int j=1; j<=M; j++)
result=max(result,flag[j]*j);
}
printf("%d\n",result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: