您的位置:首页 > 其它

PAT 1003. Emergency (25)

2016-10-14 09:28 429 查看

1003. Emergency (25)



时间限制
400 ms

内存限制
65536 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue



As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4


/* dijstra的变种
1. 求最短路的总可能路径~(每次更新节点到集合S(已找到最短路的点集)距离时  若dist[i] = dist[v0] +map[v0][i] 将
Count[i]+= Count[v0]; 若相等  则总路径数此次不变)
2. 在距离最短情况下,求最多能带多少护士去~~ (每次更新节点到集合S(已找到最短路的点集)距离时  若dist[i] = dist[v0] +map[v0][i] 将
更新护士值 为护士最多的那个值)
*/
#include "iostream"
using namespace std;
#define INF 99999999
int n, m;
int cost[501];
int Mcost[501];
int dist[501];
int map[501][501];
int Count[501] ;
void dijkstra(int v0,int n) {
bool visited[501] = { false };
dist[v0] = 0;
Mcost[v0] = cost[v0];
visited[v0] = true;
for (int i = 1; i < n; i++) {
int MIN = INF;
for (int j = 0; j < n; j++) {
if (!visited[j]) {
if (dist[j] < MIN) {
v0 = j;
MIN = dist[j];
}
}
}
visited[v0] = true;
for (int i = 0; i < n; i++) {
if (!visited[i]) {
if (dist[i] > MIN + map[v0][i] ) {
dist[i] = MIN + map[v0][i];
Mcost[i] = Mcost[v0] + cost[i];
Count[i] = Count[v0];
}
else if (dist[i] == MIN + map[v0][i] ) {
Count[i] += Count[v0];
if (Mcost[i] < Mcost[v0] + cost[i]) {
Mcost[i] = Mcost[v0] + cost[i];
}
}
}
}
}
}
int main() {
int v, e, c1, c2;
cin >> v >> e >> c1 >> c2;
for (int i = 0; i < v; i++) {
cin >> cost[i];
Count[i] = 1;
}
for (int i = 0; i < v; i++)
for (int j = 0; j < v; j++) {
map[i][j] = INF;
}
for (int i = 0; i < e; i++) {
int a, b, c;
cin >> a >> b >> c;
map[a][b] = map[b][a] = c;
if (a == c1)
Mcost[b] = cost[c1] + cost[b];
else if (b == c1)
Mcost[a] = cost[c1] + cost[a];
}
for (int i = 0; i < v; i++) {
dist[i] = map[c1][i];
}
dijkstra(c1,v);
cout << Count[c2] <<" "<<  Mcost[c2] << endl;
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: