您的位置:首页 > 其它

HDU 5135 Little Zu Chongzhi's Triangles(数学题)

2016-10-13 19:26 525 查看

Little Zu Chongzhi's Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1613    Accepted Submission(s): 889

[align=left]Problem Description[/align]
Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent
mathematician computed a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere.

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and
he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.

2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.

3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help
him so that maybe you can change the history.
 
[align=left]Input[/align]
There are no more than 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length of a stick is no more than 100. The input ends with N = 0.
 
[align=left]Output[/align]
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .
 
[align=left]Sample Input[/align]

3
1 1 20
7
3 4 5 3 4 5 90
0

 
[align=left]Sample Output[/align]

0.00
13.64


[align=left]Source[/align]
2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)
 

题意:给一些木棍,问可以组成的三角形面积的最大和是多少。
思路:贪心,从最大开始和之后两个判断是否可以组成三角形,如果不可以就再判断后三个是否可以组成三角形。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <math.h>
using namespace std;
double a[15];

double mianji(double a,double b,double c){
double p=(a+b+c)/2.0;
double s=sqrt(p*(p-a)*(p-b)*(p-c));
return s;
}

int main(){

int n;
while(~scanf("%d",&n)){
if(n==0)
break;
for(int i=0;i<n;i++)
scanf("%lf",&a[i]);
sort(a,a+n);
double sum=0;
for(int i=n-1;i>=2;){
if(a[i]<a[i-1]+a[i-2]&&a[i]>fabs(a[i-1]-a[i-2])){
sum+=mianji(a[i],a[i-1],a[i-2]);
i-=3;
}
else
i--;
}
printf("%.2f\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: