您的位置:首页 > Web前端

POJ 2492 A Bug's Life

2016-10-13 18:12 435 查看
Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 
Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
Source
TUD Programming Contest 2005, Darmstadt, Germany
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

并查集~

食物链是这道的增强版。

如果输入两虫子祖先不同,就直接加入从一开始和从n开始的并查集中;如果祖先相同,就查询是否由同一祖先。

#include<cstdio>

int t,n,m,fa[4001],flag,x,y,cnt;

int findd(int u)
{
return fa[u]==u ? u:fa[u]=findd(fa[u]);
}

int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);flag=0;
for(int i=1;i<=2*n;i++) fa[i]=i;
for(int i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
if(findd(x)==findd(y)) flag=1;
else fa[findd(y+n)]=findd(x),fa[findd(y)]=findd(x+n);
}
if(flag) printf("Scenario #%d:\nSuspicious bugs found!\n\n",++cnt);
else printf("Scenario #%d:\nNo suspicious bugs found!\n\n",++cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 并查集