您的位置:首页 > 其它

poj 2251 Dungeon Master(BFS)

2016-10-13 17:54 459 查看
Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27441 Accepted: 10748
Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and
the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 

L is the number of levels making up the dungeon. 

R and C are the number of rows and columns making up the plan of each level. 

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the
exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 

If it is not possible to escape, print the line 
Trapped!

Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output
Escaped in 11 minute(s).
Trapped!

Source

Ulm Local 1997

tip:额有一道三维数组bfs题目和hdu1253胜利大逃亡一个思路

先记录下起点终点坐标....广搜一遍.....如果能到达终点输出,否则输出trapped!

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;

int sx,sy,sz,ez,ex,ey;

char mp[33][33][33];
struct node{
int x,y,z,step;
};
int h,n,m;
int book[43][43][43];
int go[][3]={-1,0,0,
1,0,0,
0,-1,0,0,1,0,
0,0,-1,0,0,1
};

int bfs()
{
queue<node>q;
book[sx][sy][sz]=1;
q.push(node{sx,sy,sz,0}) ;
while(!q.empty())
{
node tt=q.front();q.pop();
int x=tt.x;int y=tt.y;int z=tt.z;

if(x==ex&&y==ey&&z==ez){
return tt.step;
}

for(int i=0;i<6;i++)
{
int nx=x+go[i][0];
int ny=y+go[i][1];
int nz=z+go[i][2];

if(nx<1||nx>n||ny<1||ny>m||nz<1||nz>h)continue;
if(!book[nx][ny][nz]&&mp[nx][ny][nz]!='#'){
book[nx][ny][nz]=1;
q.push(node{nx,ny,nz,tt.step+1});

}
}
}
return -1;
}
int main()
{
while(scanf("%d %d %d",&h,&n,&m))
{
if(n==0&&m==0&&h==0)break;
memset(book,0,sizeof(book));
for(int i=1;i<=h;i++)
{
for(int j=1;j<=n;j++)
{
for(int k=1;k<=m;k++)
{
char x;cin>>x;
mp[j][k][i]=x;
if(x=='S')sx=j,sy=k,sz=i;
if(x=='E')ex=j,ey=k,ez=i;
}
}
}
int t=bfs();
if(t<0)cout<<"Trapped!"<<endl;
else cout<<"Escaped in "<<t<<" minute(s)."<<endl;

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: