您的位置:首页 > 其它

hdu2845 DP最大不连续子段和

2016-10-12 21:17 453 查看

                                                         Beans

[b]                                                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

                                                                     Total Submission(s): 4487    Accepted Submission(s): 2114
[/b]

[align=left]Problem Description[/align]
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect
the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.



Now, how much qualities can you eat and then get ?
 

[align=left]Input[/align]
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that
the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

[align=left]Output[/align]
For each case, you just output the MAX qualities you can eat and then get.
 

[align=left]Sample Input[/align]

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

 

[align=left]Sample Output[/align]

242

 
题意:给你一个矩阵,让你找出这个矩阵元素的最大和,限制条件是:当你取了一个元素时,这个元素的上一行元素和下一行元素都不能取,而且这个元素左右两边的元素也不能取。
思路:很显然,我们需要确定要取哪些行的元素,要舍弃哪些行,而我们取某一行元素时,必然是取能使这一行和最大的元素相加,然后我们记录第 i 行的最大值为sum[ i ],然后当我们把 n 行都做完时,这就又成了在sum数组中取能使sum数组和最大的元素了。
那么我们怎么取能使一行最大的元素呢?很显然,某一个元素的无非两种状态,取或者不取,那么我们让dp[ i ][ 0 ]为第 i 个元素不取,1~i 这个子区间的最大值,而dp[ i ][ 1 ]为取第 i 个元素,1~i 这个子区间的最大值,那么状态转移方程为
dp[k][0] = max(dp[k-1][1],dp[k-1][0]);

dp[k][1] = dp[k-1][0] + a[k];

贴一下代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define MAXX 200050
#define INF 0xfffffff
using namespace std;
int a[MAXX];
int dp[MAXX][2];
int sum[MAXX];
int solve(int *p, int n){
for(int i = 1; i <= n; i++){
dp[i][0] = max(dp[i-1][1],dp[i-1][0]);
dp[i][1] = dp[i-1][0] + p[i];
}
return max(dp
[0],dp
[1]);
}
int main(){
int n,m;
while(scanf("%d%d",&n,&m) == 2){
//memset(dp,0,sizeof(dp));
for(int i = 1; i <= n; i++){
for(int j = 1; j <= m; j++)
scanf("%d",&a[j]);
sum[i] = solve(a,m);
}
cout << solve(sum,n) << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: