您的位置:首页 > 其它

Message Flood sdutoj 1500 (STL map 的使用)

2016-10-12 21:04 417 查看

Message Flood

Time Limit: 1500MS
Memory Limit: 65536KB
[align=center][/align]
[align=center][/align]

Problem Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What
a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin
has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs
to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed
to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the
length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Example Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0


Example Output

3


///map 大致理解为二维数组
#include <bits/stdc++.h>

using namespace std;

int main()
{
int n,m;
int i,j;
while (cin>>n&&n)
{
cin>>m;
map<string,int>mp; /// 初始时 int / string(second)==0 / '\0',
string s;
for (i=1; i<=n; i++)
{
cin>>s;
for (j=0; j<s.size(); j++)
{
s[j]=towlower(s[j]);///  towlower()转换为小写字母
}
mp[s]++;
}
for (i=1; i<=m; i++)
{
cin>>s;
for (j=0; j<s.size(); j++)
{
s[j]=towlower(s[j]);
}
mp.erase(s);///删除s元素
}
cout<<mp.size()<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息