您的位置:首页 > 其它

POJ 1631 LIS 模板题

2016-10-12 20:37 453 查看
Description'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of twofunctional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridgingis a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearingin mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbersin the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.InputOn the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000,the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.OutputFor each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.Sample Input
4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6
Sample Output
3
9
1
4
写法1.1
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <queue>

using namespace std;

typedef long long LL;
const int inf = 0x3f3f3f3f;
const int N = 40005;

int a[N], dp[N];
int n;

int main()
{
int t, i;

scanf("%d", &t);

while(t--)
{
scanf("%d", &n);

memset(dp, 0 ,sizeof(dp));

for(i = 0;i<n;i++)
{
scanf("%d", &a[i]);
}
fill(dp, dp+n, inf);
for(int i = 0;i<n;i++)
{
*lower_bound(dp, dp+n, a[i])= a[i];
}

printf("%d\n", lower_bound(dp, dp+n,inf)-dp);
}

return 0;
}
写法1.2
#include <iostream>#include <cstdio>#include <cstring>#include <algorithm>using namespace std;const int N = 40050;int main(){int a[N], b[N];int n, i,  t;scanf("%d", &t);while(t--){scanf("%d", &n);for(i = 0;i < n;i++){scanf("%d", &a[i]);}memset(b, 1 ,sizeof(b));int ans = 0, x ;for(i = 0; i < n ;i++){x = lower_bound(b, b+n, a[i])-b;b[x] = a[i];ans = max(x + 1, ans);}printf("%d\n", ans);}return 0;}
写法2.1
#include <iostream>#include <algorithm>#include <cstdio>#include <cstring>#include <cmath>using namespace std;const int N =40001;typedef long long LL;const int inf = 0x3f3f3f3f;int a[N], len[N];int main(){int n, i, l, r, mid, top, t;scanf("%d", &t);while(t--){scanf("%d", &n);for(i = 0 ; i<n; i++){scanf("%d", &a[i]);}len[0]=-inf;top = 0;for(i = 0; i<n; i++){if(a[i]>len[top])len[++top]=a[i];else{l = 1, r = top;while(l<r){mid = (r + l)>>1;if(len[mid]>=a[i])r = mid;elsel = mid + 1;}len[l]=a[i];}}printf("%d\n", top);}return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: